package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\((?:[^)(]+|\((?:[^)(]+|\([^)(]*\))*\))*\)`)
var str = `Financial Operations (Financing, Customer Payment, and Settlement (AR), Collaborative Financial Processing, Vendor Invoice Verification and Processing (AP),Bank processes and Relationship Management, Allocation of Shared Services), Accounting(Financial statements, General Ledger and Subledger, Revenue and Cost Accounting, Job and Product Accounting, Product and Service Costing ), Corporate Services (Real estate management, Travel management (TEAs), Treasury and finance management ) Human Resource Management (HR Strategy and Planning, Recruitment, Payroll, Compensation and Total Benefits, Employee Development ), Manufacturing and Logistics (Production planning, materials management, inventory management, order entry and processing, warehouse mgmt, transportation mgmt, project mgmt, plant maintenance, customer service mgmt)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}