# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\((?:[^)(]+|\((?:[^)(]+|\([^)(]*\))*\))*\)"
test_str = "Financial Operations (Financing, Customer Payment, and Settlement (AR), Collaborative Financial Processing, Vendor Invoice Verification and Processing (AP),Bank processes and Relationship Management, Allocation of Shared Services), Accounting(Financial statements, General Ledger and Subledger, Revenue and Cost Accounting, Job and Product Accounting, Product and Service Costing ), Corporate Services (Real estate management, Travel management (TEAs), Treasury and finance management ) Human Resource Management (HR Strategy and Planning, Recruitment, Payroll, Compensation and Total Benefits, Employee Development ), Manufacturing and Logistics (Production planning, materials management, inventory management, order entry and processing, warehouse mgmt, transportation mgmt, project mgmt, plant maintenance, customer service mgmt)"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.