#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?:>[a-zA-z0-9@:. -,-]+))"
Local $sString = "<title-group>" & @CRLF & _
"<title>abcdefghjtshdfg<email>EffectiveHealthCare@ahrq.hhs.gov</email>dfgdfgg</title>" & @CRLF & _
"</title-group>" & @CRLF & _
"</book-part-meta>" & @CRLF & _
"<body>" & @CRLF & _
"<p><bold>" & @CRLF & _
"<italic>Comparative Effectiveness Review</italic>" & @CRLF & _
"</bold></p>" & @CRLF & _
"<p><bold>Number 154</bold></p>" & @CRLF & _
"<p><bold>Prepared for:</bold></p>" & @CRLF & _
"<p>Agency for Healthcare Research and Quality</p>" & @CRLF & _
"<p>U.S. Department of Health and Human Services</p>" & @CRLF & _
"<p>540 Gaither Road</p>" & @CRLF & _
"<p>Rockville, MD 20850</p>" & @CRLF & _
"<p><ext-link xlink:href="www.ahrq.gov" ext-link-type="uri">www.ahrq.gov</ext-link></p>" & @CRLF & _
"<p><bold>Contract No. 290-2012-00009-I</bold></p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")