// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((?:>[a-zA-z0-9@:. -,-]+))").unwrap();
let string = "<title-group>
<title>abcdefghjtshdfg<email>EffectiveHealthCare@ahrq.hhs.gov</email>dfgdfgg</title>
</title-group>
</book-part-meta>
<body>
<p><bold>
<italic>Comparative Effectiveness Review</italic>
</bold></p>
<p><bold>Number 154</bold></p>
<p><bold>Prepared for:</bold></p>
<p>Agency for Healthcare Research and Quality</p>
<p>U.S. Department of Health and Human Services</p>
<p>540 Gaither Road</p>
<p>Rockville, MD 20850</p>
<p><ext-link xlink:href=\"www.ahrq.gov\" ext-link-type=\"uri\">www.ahrq.gov</ext-link></p>
<p><bold>Contract No. 290-2012-00009-I</bold></p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}