$re = '/\b(?<!\b[aA][sS][pP])(?<!\b[vV][bB]|\b[cC]\#)\.[a-zA-Z]{2,6}\b/';
$str = 'asp.net somedomain.com vb.net otherdomain.org wax.museum $%^&.alpha rasp.net ASP.net VB.net C#.az';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);