re = /\b(?<!\b[aA][sS][pP])(?<!\b[vV][bB]|\b[cC]\#)\.[a-zA-Z]{2,6}\b/
str = 'asp.net somedomain.com vb.net otherdomain.org wax.museum $%^&.alpha rasp.net ASP.net VB.net C#.az'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end