import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = """;
final String string = ""href":"\\/wikis\\/uncharted-4-a-thiefs-end\\/Prologue","label":"Prologue","sub":[],"sub_cn":["ghn-tertNav"],"expanded":false},{"cn":["ghn-L2","ghn-noSub"],"href":"\\/wikis\\/uncharted-4-a-thiefs-end\\/Chapter_01%3A_The_Lure_of_Adventure","label":"Chapter 01: The Lure of Adventure","sub":[],"sub_cn":["ghn-tertNav"],"expanded":false},{"cn":["ghn-L2","ghn-noSub"],"href":"\\/wikis\\/uncharted-4-a-thiefs-end\\/Chapter_02%3A_Infernal_Place","label":"Chapter 02: Infernal Place","sub":[],"sub_cn":["ghn-tertNav"],"expanded":false},{"cn":["ghn-L2","ghn-noSub"],"href":"\\/wikis\\/uncharted-4-a-thiefs-end\\/Chapter_03%3A_The_Malaysia_Job","label":"Chapter 03: The Malaysia Job","sub":[],"sub_cn":["ghn-tertNav"],";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}