re = /([\w]+[.][\w]+)*=*'{\#FVD([\d]+)\}/
str = 'EQU.ST_CODLON=\'{#FVD242002}\''
# Print the match result
str.match(re) do |match|
puts match.to_s
end