package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Z0-9\-_\.]+):([0-9]{1,5})`)
var str = `127.0.0.1:45681
56.22.67.11:14
lombao.net:543
proxis semaforos.ly:326`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}