#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\w+)\/(\w+)(?:\+(\w+))?|(?<!^)\G(?:\s?;\s?(\w+)=([\w\.]+))"
Local $sString = "application/xhtml+xml; q=0.9; level=3 , text/html,application/json;test=hello" & @CRLF & _
"" & @CRLF & _
"application/xhtml+json; q=1000; level=4 , " & @CRLF & _
"" & @CRLF & _
"application/ " & @CRLF & _
"q=0.9;" & @CRLF & _
"" & @CRLF & _
"application/;q=3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")