package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)((([a-zA-Z]|[0-9])|([-]|[_]|[.]))+[@](([a-zA-Z0-9])|([-])){2,63}[.](([a-zA-Z0-9]){2,63})[.](([a-zA-Z0-9]){2,63}))|((([a-zA-Z]|[0-9])|([-]|[_]|[.]))+[@](([a-zA-Z0-9])|([-])){2,63}[.](([a-zA-Z0-9]){2,63}))`)
var str = `hello@world.com hello@world.co.uk `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}