$re = '/(?:(?:\,[,^.]{0,}|^)(foobar)[,^.]{0,})/';
$str = 'foobar,foobar123,abc,foo,bar,foObar,,,foobar,f,dfg,$foobar£,foobar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);