Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
((([0-9]*\.[0-9]+)|([0-9]+\.[0-9]*))(E(\+|-)?[0-9]+)?)|([0-9]+(E(\+|-)?[0-9]+))
/
m
Input 1
1
New
1.123 1.E123