use strict;
my $str = '},null,"「奇跡? ……そ、そうだ! これは奇跡…… なら、この奇跡を利用しない手はないんじゃ!」","「奇跡? ……そ、そうだ! これは奇跡…… なら、この奇跡を利用しない手はないんじゃ!」"],["player",null,"「利用……?」",null,64,{
"data": [["bg","stage",{
"action": [["zpos",233.33333333333337]],
"class": "stage",
"name": "bg",
"redraw": {
"disp": 2,
"imageFile": {
"file": "bg03.mtn",
"options": {
"chara": "背景",
"motion": "昼"
}
';
my $regex = qr/(?<=null,)(.*?)(?=,null,(?:[0-9]{1,3})(?:,|$))|(?<=chara":|motion":)([^,\n]*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}