# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=null,)(.*?)(?=,null,(?:[0-9]{1,3})(?:,|$))|(?<=chara\":|motion\":)([^,\n]*)"
test_str = ("},null,\"「奇跡? ……そ、そうだ! これは奇跡…… なら、この奇跡を利用しない手はないんじゃ!」\",\"「奇跡? ……そ、そうだ! これは奇跡…… なら、この奇跡を利用しない手はないんじゃ!」\"],[\"player\",null,\"「利用……?」\",null,64,{\n"
" \"data\": [[\"bg\",\"stage\",{\n"
" \"action\": [[\"zpos\",233.33333333333337]],\n"
" \"class\": \"stage\",\n"
" \"name\": \"bg\",\n"
" \"redraw\": {\n"
" \"disp\": 2,\n"
" \"imageFile\": {\n"
" \"file\": \"bg03.mtn\",\n"
" \"options\": {\n"
" \"chara\": \"背景\",\n"
" \"motion\": \"昼\"\n"
" }\n"
" \n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.