import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{3}) - (\\d{8}) #region code, -, phone number\n"
+ "| #alternative\n"
+ "(\\d{4}) - (\\d{7,8})#region code, -, phone number";
final String string = "021-54749110 \n"
+ "0531-88881234\n"
+ "0635-8238080";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}