$re = '/key\s*=\s*"(Lock.Id)"\s+value\s*=\s*"([^\"]+)"/';
$str = '<add key="Lock.Id" value="TestingRPI-01" />
<add key="Lock.Id" value="TestingRPI-01" />
<add key="Lock.Id" value="TestingRPI-01" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);