#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)https?:\/\/\w+(?:\.\w+\/?)+(?!\.{3})(\s|$)"
Local $sString = "sometext http://google.com sometext http://google.com/ sometext https://google.com sometext https://google.com/ sometext //google.com sometext //google.com/ sometext //g-o-o.g-l-e.com sometext http://goog… sometext https://go… sometext https://google sometext https://google.com/blah… sometext"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")