import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S[^\\.]*)(\\.(\\S*))?@(\\S*)";
final String string = "jim.beam@no.com\n"
+ "jim@no.com\n"
+ "jo-ei@jim.beam\n"
+ "gu@stav-to.cc\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}