import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\/^](leaflet|mapbox)[\\-\\._]?([\\w\\-\\._]*)\\.js\\??";
final String string = "leaflet-0.7.2.js\n"
+ "^leaflet-0.7.2.js <-- Does anyone actually uses \"^\" in a filename?\n"
+ "/leaflet-0.7.2.js\n"
+ "http://leafletjs.com/dist/leaflet.js\n"
+ "https://api.tiles.mapbox.com/mapbox.js/v1.6.3/mapbox.js\n"
+ "http://example.com/path/to/leaflet-0.7.2.js\n"
+ "http://example.com/path/to/mapbox-v1.6.2.js\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}