import re
regex = re.compile(r"([\W\S]\s[\w\W]{2}.+),\s(.+)\1([!?.])", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Dios mÃo, ¡está aquÃ, está aquÃ, está aquÃ!\n\n"
"¿Qué paso, qué paso?\n\n"
"Me rehúso, me rehúso.\n\n"
"No, no, no, no.")
subst = "$1$3"
result = regex.sub(subst, test_str)
if result:
print(result)