using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Esta condición)?(?(1) es verdadera| es falsa)";
string input = @"Esta condición es verdadera
Esta otra es falsa
Aquí no se debe seleccionar nada";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}