re = /(Esta condición)?(?(1) es verdadera| es falsa)/
str = 'Esta condición es verdadera
Esta otra es falsa
Aquí no se debe seleccionar nada'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end