// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(Esta condición)?(?(1) es verdadera| es falsa)").unwrap();
let string = "Esta condición es verdadera
Esta otra es falsa
Aquí no se debe seleccionar nada";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}