package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)limit+([\s\S]+)`)
var str = `✔ nnn : am
-limitaaaa
ça UNICODE HERE
sdasdsadaw
✔ UNICODE HERE
limitaaaa,.@#!~\`%$&*()[]{}|\+=-_?/'":;.><,
777723xx sss fff s :,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}