$re = '/\-(moz|o|webkit|ms|khtml)\-(?!font-smoothing|osx|print).+?;/';
$str = '.box {
float: right;
padding: 0.8em 0.8em 0.4em 0.8em;
background-color: #f0f0f0;
border-radius: 0.4em;
-moz-border-radius: 0.4em;
-o-border-radius: 0.4em;
-webkit-border-radius: 0.4em;
-ms-border-radius: 0.4em;
-webkit-font-smoothing: antialiased;
-moz-osx-font-smoothing: grayscale;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);