using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"query (?P<function_name>\S*)\s+?(\((?P<function_args>.+?)\))?\s+?{";
string input = @"query get_telemetry (name: String, start_time: String, end_time: String) {
parameters:satelliteOperatorInteractionParameters(name: $name) {
edges {
node {
name
path
states(timestamp_Gte: $start_time, timestamp_Lte: $end_time) {
edges {
node {
timestamp
calibrated_value:calibratedValue
}
}
}
}
}
}
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}