package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)query (?P<function_name>\S*)\s+?(\((?P<function_args>.+?)\))?\s+?{`)
var str = `query get_telemetry (name: String, start_time: String, end_time: String) {
parameters:satelliteOperatorInteractionParameters(name: $name) {
edges {
node {
name
path
states(timestamp_Gte: $start_time, timestamp_Lte: $end_time) {
edges {
node {
timestamp
calibrated_value:calibratedValue
}
}
}
}
}
}
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}