import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "query (?P<function_name>\\S*)\\s+?(\\((?P<function_args>.+?)\\))?\\s+?\\{";
final String string = "query get_telemetry (name: String, start_time: String, end_time: String) {\n"
+ " parameters:satelliteOperatorInteractionParameters(name: $name) {\n"
+ " edges {\n"
+ " node {\n"
+ " name\n"
+ " path\n"
+ " states(timestamp_Gte: $start_time, timestamp_Lte: $end_time) {\n"
+ " edges {\n"
+ " node {\n"
+ " timestamp\n"
+ " calibrated_value:calibratedValue\n"
+ " }\n"
+ " }\n"
+ " }\n"
+ " }\n"
+ " }\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}