import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(\\w+\\b)[^>]*>([\\S\\s]*?)<\\/\\1>";
final String string = "if <p>TEXT</p> gsufgus <p>testesss</p> this is print: \"TEXT gsufgus testesss\" and i want print only : \"TEXT testesss\"\n"
+ "<p>fasfsd</p> and <h1>asfdf</h1>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}