import Foundation
let pattern = #"<(\w+\b)[^>]*>([\S\s]*?)<\/\1>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
if <p>TEXT</p> gsufgus <p>testesss</p> this is print: "TEXT gsufgus testesss" and i want print only : "TEXT testesss"
<p>fasfsd</p> and <h1>asfdf</h1>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)