re = /"^((0?[1-9]|1[012])[- .](0?[1-9]|[12][0-9]|3[01])[- .](19|20)?[0-9]{4})*$"/m
str = '01-01-2019'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end