#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\);\s*$"
Local $sString = "("{scriptid}_*0123_00000000_ABC-Description*");" & @CRLF & _
"" & @CRLF & _
"("{scriptid}_4-digits_8-alphanumeric_X-alphanumeric-description");" & @CRLF & _
""
Local $sSubst = "\)\);"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)