import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\);\\s*$";
final String string = "(\"{scriptid}_*0123_00000000_ABC-Description*\");\n\n"
+ "(\"{scriptid}_4-digits_8-alphanumeric_X-alphanumeric-description\");\n";
final String subst = "\\)\\);";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}