const regex = /\);\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\);\\s*$', 'gm')
const str = `("{scriptid}_*0123_00000000_ABC-Description*");
("{scriptid}_4-digits_8-alphanumeric_X-alphanumeric-description");
`;
const subst = `\)\);`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);