$re = '/\);\s*$/m';
$str = '("{scriptid}_*0123_00000000_ABC-Description*");
("{scriptid}_4-digits_8-alphanumeric_X-alphanumeric-description");
';
$subst = "\)\);";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;