#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=(\d{1,3}\.){3}\d{1,3})((?:(2[0-5]{2}|[1]?\d{1,2}))\.){3}(?:(2[0-5]{2}|[1]?\d{1,2}))(?![\.\d])"
Local $sString = "1.2.3.4 255.100.196.123 256.100.203.1 1.2.3.4 1.2.3.4.5 123.456.78.90 123.45.67.89" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")