$re = '/(\w*\.?)(?:guestofaguest\.)(\w*)/';
$str = ' http://admin.guestofaguest.com/
http://dc.guestofaguest.com/
http://dev.guestofaguest.com/
http://guestofaguest.com/
http://hamptons.guestofaguest.com/
http://la.guestofaguest.com/
http://www.guestofaguest.com/';
$subst = "guestofaguest.com";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;