import Foundation
let pattern = #"(\w*\.?)(?:guestofaguest\.)(\w*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://admin.guestofaguest.com/
http://dc.guestofaguest.com/
http://dev.guestofaguest.com/
http://guestofaguest.com/
http://hamptons.guestofaguest.com/
http://la.guestofaguest.com/
http://www.guestofaguest.com/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"guestofaguest.com"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)