using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(?:[A-Z]{3}\s){2})[0-9]{3}";
string input = @"QA 44
ABQ DAL 280
ABQ HOU 290
HOU PHX 210
DAL PHX 102";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}