$re = '/(?<=(?:[A-Z]{3}\s){2})[0-9]{3}/';
$str = 'QA 44
ABQ DAL 280
ABQ HOU 290
HOU PHX 210
DAL PHX 102';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);