import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\n"
+ " (?:\n"
+ " (?:автомобиля\\s{0,5})\n"
+ " (?:\\w{1,25}\\s{1,5}){0,3}\\W{0,2}не)|\n"
+ " (?:\n"
+ " (?:ука(?:зать|жи(?:те|))[\\s:,-]{0,5})\n"
+ " (?:\\w{1,25}[\\s:,-]{0,5}){0,5}наличие)\n"
+ ")\\b";
final String string = "Просьба присылать подробное резюме с фотографией на почту, укажите: пожалуйста , наличие автомобиля.\n"
+ "Просьба присылать подробное резюме с фотографией на почту, укажите пожалуйста наличие автомобиля.\n"
+ "Просьба присылать подробное резюме с фотографией на почту, укажите,пожалуйста - наличие автомобиля.\n\n"
+ "наличие автомобиля не обязательно, не требуется \n\n\n"
+ "Наличие автомобиля не является обязательным. \n"
+ "Наличие автомобиля совершенно не обязательно.\n"
+ "Наличие личного автомобиля так же не обязательно\n"
+ "Наличие личного автомобиля не обязательно\n"
+ "Наличие личного автомобиля (не обязательно)\n"
+ "Наличие личного автомобиля-не обязательно\n"
+ "Наличие личного автомобиля - не обязательно\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}