const regex = new RegExp('\\b(
(?:
(?:автомобиля\\s{0,5})
(?:\\w{1,25}\\s{1,5}){0,3}\\W{0,2}не)|
(?:
(?:ука(?:зать|жи(?:те|))[\\s:,-]{0,5})
(?:\\w{1,25}[\\s:,-]{0,5}){0,5}наличие)
)\\b', 'gmiu')
const str = `Просьба присылать подробное резюме с фотографией на почту, укажите: пожалуйста , наличие автомобиля.
Просьба присылать подробное резюме с фотографией на почту, укажите пожалуйста наличие автомобиля.
Просьба присылать подробное резюме с фотографией на почту, укажите,пожалуйста - наличие автомобиля.
наличие автомобиля не обязательно, не требуется
Наличие автомобиля не является обязательным.
Наличие автомобиля совершенно не обязательно.
Наличие личного автомобиля так же не обязательно
Наличие личного автомобиля не обязательно
Наличие личного автомобиля (не обязательно)
Наличие личного автомобиля-не обязательно
Наличие личного автомобиля - не обязательно
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}