use strict;
my $str = 'Просьба присылать подробное резюме с фотографией на почту, укажите: пожалуйста , наличие автомобиля.
Просьба присылать подробное резюме с фотографией на почту, укажите пожалуйста наличие автомобиля.
Просьба присылать подробное резюме с фотографией на почту, укажите,пожалуйста - наличие автомобиля.
наличие автомобиля не обязательно, не требуется
Наличие автомобиля не является обязательным.
Наличие автомобиля совершенно не обязательно.
Наличие личного автомобиля так же не обязательно
Наличие личного автомобиля не обязательно
Наличие личного автомобиля (не обязательно)
Наличие личного автомобиля-не обязательно
Наличие личного автомобиля - не обязательно
';
my $regex = qr/\b(
(?:
(?:автомобиля\s{0,5})
(?:\w{1,25}\s{1,5}){0,3}\W{0,2}не)|
(?:
(?:ука(?:зать|жи(?:те|))[\s:,-]{0,5})
(?:\w{1,25}[\s:,-]{0,5}){0,5}наличие)
)\b/mixup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}