use strict;
my $str = 'console.log(dasdsadsadasdaddasd);
console.log(dsadsadsadasddsadsadsassssssssssssssssssssssssssssssssssssssssssssssssssssssssssssdsadsadsadsadxczxczxcxzczxcxzcxzc);';
my $regex = qr/(?=\s*?)(console)\.(log)\((.*?)\)(\;|\s*?)/mip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";