const regex = /(\bno\b|\bsin\b|nunca|evit(e|a|ar)|abstene|rehui|recusa).{0,16}(inici(e|es|ar)|abr(ir|as)|hacer|hagas|hace|reali(za|ce)|levant(a|e)|subir|crear|efectu[ea]|ingreses|gener[ae]).{0,16}reclamo/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\bno\\b|\\bsin\\b|nunca|evit(e|a|ar)|abstene|rehui|recusa).{0,16}(inici(e|es|ar)|abr(ir|as)|hacer|hagas|hace|reali(za|ce)|levant(a|e)|subir|crear|efectu[ea]|ingreses|gener[ae]).{0,16}reclamo', 'gm')
const str = `¡el producto que compraste fue entregado ¡muchas gracias alaineduardo. importante en caso de necesitar algun garantia o ajuste de talla, debes de contactarnos directamente por este chat o llamar al %tel y te ayudaremos. evita realizar cualquier reclamos antes de contactarnos para efectos de talla, garantia o servicio para poder brindarte una mejor atencion. de nuevo muchas gracias por tu confianza. saludos si le quedo grande puedes compra un ajustador en esta liga %url seguro por accidente y mantenimiento gratis piezas marloz a solo %num . pesos en esta liga %url`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}