const regex = /(?s)<Device(?:(?!<\/Device).)*<Block[^>]+Name="ZG123CZ123".*?<\/Device>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)<Device(?:(?!<\\\/Device).)*<Block[^>]+Name="ZG123CZ123".*?<\\\/Device>', 'g')
const str = `<Device DevID="14212111" Model="" GroupID="">
<Block Name="ZG123CZ123" LastFileDld="" LastFullDld="">
<Group ZD="1">
<DSize ParamName="KEY" Value="RAM"/>
<DSize ParamName="REM" Value="***"/>
<DSize ParamName="*UNZIP" Value="I:ZG123CZ123.ZIP"/>
</Group>
<Group ZD="15">
<DSize ParamName="REM" Value="="***""/>
<DSize ParamName="#DEBUGPORT" Value=""/>
</Group>
</Block>
<DevFiles />
</Device>
<Device DevID="14212111" Model="" GroupID="">
<Block Name="DG" LastFileDld="" LastFullDld="">
<Group ZD="3">
<DSize ParamName="*UNZIP" Value="DG.ZIP"/>
<DSize ParamName="*GO" Value="F:DG.OUT"/>
</Group>
<Group ZD="15">
<DSize ParamName="#LOGPORT" Value="NONE"/>
<DSize ParamName="CDH6" Value=""/>
</Group>
</Block>
<DevFiles />
</Device>
<Device DevID="14212111" Model="" GroupID="">
<Block Name="ZG123CZ123" LastFileDld="" LastFullDld="">
<Group ZD="1">
<DSize ParamName="KEY" Value="RAM"/>
<DSize ParamName="REM" Value="***"/>
<DSize ParamName="*UNZIP" Value="I:ZG123CZ123.ZIP"/>
</Group>
<Group ZD="15">
<DSize ParamName="REM" Value="="***""/>
<DSize ParamName="#DEBUGPORT" Value=""/>
</Group>
</Block>
<DevFiles />
</Device>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}