$re = '/^\w+$/mu';
$str = 'correct
foobar
foo bar
bar-foo
foo.bar
noway, sir
definitelynot
unicodeæøå';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);