# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^+0-9\n]+[^(?:\s+0-9)*]"
test_str = ("๐ฆ๐ซ Afghanistan +93\n"
"๐ฆ๐ฝ ร
land Islands +358\n"
"๐ฆ๐ฑ Albania +355\n"
"๐ฉ๐ฟ Algeria +213\n"
"๐ฆ๐ธ American Samoa +1684\n"
"๐ฆ๐ฉ Andorra +376\n"
"๐ฆ๐ด Angola +244\n"
"๐ฆ๐ฎ Anguilla +1264\n"
"๐ฆ๐ฌ Antigua & Barbuda +1268\n"
"๐ฆ๐ท Argentina +54\n"
"๐ฆ๐ฒ Armenia +374\n"
"๐ฆ๐ผ Aruba +297\n"
"๐ฆ๐บ Australia +61\n"
"๐ฆ๐น Austria +43\n"
"๐ฆ๐ฟ Azerbaijan +994\n"
"๐ง๐ธ Bahamas +1242\n"
"๐ง๐ญ Bahrain +973\n"
"๐ง๐ฉ Bangladesh +880\n"
"๐ง๐ง Barbados +1246\n"
"๐ง๐พ Belarus +375\n"
"๐ง๐ช Belgium +32\n"
"๐ง๐ฟ Belize +501\n"
"๐ง๐ฏ Benin +229\n"
"๐ง๐ฒ Bermuda +1441\n"
"๐ง๐น Bhutan +975\n"
"๐ง๐ด Bolivia +591\n"
"๐ง๐ฆ Bosnia & Herzegovina +387\n"
"๐ง๐ผ Botswana +267\n"
"๐ง๐ท Brazil +55\n"
"๐ฎ๐ด British Indian Ocean Territory +246\n"
"๐ป๐ฌ British Virgin Islands +1284\n"
"๐ง๐ณ Brunei +673\n"
"๐ง๐ฌ Bulgaria +359\n"
"๐ง๐ซ Burkina Faso +226\n"
"๐ง๐ฎ Burundi +257\n"
"๐ฐ๐ญ Cambodia +855\n"
"๐จ๐ฒ Cameroon +237\n"
"๐จ๐ฆ Canada +1\n"
"๐จ๐ป Cape Verde +238\n"
"๐ณ๐ฑ Carribbean Netherlands +599\n"
"๐ฐ๐พ Cayman Islands +1345\n"
"๐จ๐ซ Central African Republic +236\n"
"๐น๐ฉ Chad +235\n"
"๐จ๐ฑ Chile +56\n"
"๐จ๐ณ China +86\n"
"๐จ๐ฝ Christmas Islands +61\n"
"๐จ๐จ Cocos Islands +61\n"
"๐จ๐ด Colombia +57\n"
"๐ฐ๐ฒ Comoros +269\n"
"๐จ๐ฉ Congo-Kinshasa +243\n"
"๐จ๐ฌ Congo-Brazzaville +242\n"
"๐จ๐ฐ Cook Islands +682\n"
"๐จ๐ท Costa Rica +506\n"
"๐ญ๐ท Croatia +385\n"
"๐จ๐บ Cuba +53\n"
"๐จ๐ผ Curaรงao +599\n"
"๐จ๐พ Cyprus +357\n"
"๐จ๐ฟ Czechia +420\n"
"๐ฉ๐ฐ Denmark +45\n"
"๐ฉ๐ฏ Djibouti +253\n"
"๐ฉ๐ฒ Dominica +1767\n"
"๐ฉ๐ด Dominican Republic +1\n"
"๐ช๐จ Ecuador +593\n"
"๐ช๐ฌ Egypt +20\n"
"๐ธ๐ป El Salvador +503\n"
"๐ฌ๐ถ Equatorial Guinea +240\n"
"๐ช๐ท Eritrea +291\n"
"๐ช๐ช Estonia +372\n"
"๐ช๐น Ethiopia +251\n"
"๐ซ๐ฐ Falkland Islands +500\n"
"๐ซ๐ด Faroe Islands +298\n"
"๐ซ๐ฏ Fiji +679\n"
"๐ซ๐ฎ Finland +358\n"
"๐ซ๐ท France +33\n"
"๐ฌ๐ซ French Guiana +594\n"
"๐ต๐ซ French Polynesia +689\n"
"๐ฌ๐ฆ Gabon +241\n"
"๐ฌ๐ฒ Gambia +220\n"
"๐ฌ๐ช Georgia +995\n"
"๐ฉ๐ช Germany +49\n"
"๐ฌ๐ญ Ghana +233\n"
"๐ฌ๐ฎ Gibraltar +350\n"
"๐ฌ๐ท Greece +30\n"
"๐ฌ๐ฑ Greenland +299\n"
"๐ฌ๐ฉ Grenada +1473\n"
"๐ฌ๐ต Guadeloupe +590\n"
"๐ฌ๐บ Guam +1671\n"
"๐ฌ๐น Guatemala +502\n"
"๐ฌ๐ฌ Guernsey +44\n"
"๐ฌ๐ณ Guinea +224\n"
"๐ฌ๐ผ Guinea-Bissau +245\n"
"๐ฌ๐พ Guyana +592\n"
"๐ญ๐น Haiti +509\n"
"๐ญ๐ณ Honduras +504\n"
"๐ญ๐ฐ Hong Kong +852\n"
"๐ญ๐บ Hungary +36\n"
"๐ฎ๐ธ Iceland +354\n"
"๐ฎ๐ณ India +91\n"
"๐ฎ๐ฉ Indonesia +62\n"
"๐ฎ๐ท Iran +98\n"
"๐ฎ๐ถ Iraq +964\n"
"๐ฎ๐ช Ireland +353\n"
"๐ฎ๐ฒ Isle of Man +44\n"
"๐ฎ๐ฑ Israel +972\n"
"๐ฎ๐น Italy +39\n"
"๐จ๐ฎ Ivory Coast +225\n"
"๐ฏ๐ฒ Jamaica +1\n"
"๐ฏ๐ต Japan +81\n"
"๐ฏ๐ช Jersey +44\n"
"๐ฏ๐ด Jordan +962\n"
"๐ฐ๐ฟ Kazakhstan +7\n"
"๐ฐ๐ช Kenya +254\n"
"๐ฐ๐ฎ Kiribati +686\n"
"๐ฝ๐ฐ Kosovo +383\n"
"๐ฐ๐ผ Kuwait +965\n"
"๐ฐ๐ฌ Kyrgyzstan +996\n"
"๐ฑ๐ฆ Laos +856\n"
"๐ฑ๐ป Latvia +371\n"
"๐ฑ๐ง Lebanon +961\n"
"๐ฑ๐ธ Lesotho +266\n"
"๐ฑ๐ท Liberia +231\n"
"๐ฑ๐พ Libya +218\n"
"๐ฑ๐ฎ Liechtenstein +423\n"
"๐ฑ๐น Lithuania +370\n"
"๐ฑ๐บ Luxembourg +352\n"
"๐ฒ๐ด Macau +853\n"
"๐ฒ๐ฌ Madagascar +261\n"
"๐ฒ๐ผ Malawi +265\n"
"๐ฒ๐พ Malaysia +60\n"
"๐ฒ๐ป Maldives +960\n"
"๐ฒ๐ฑ Mali +223\n"
"๐ฒ๐น Malta +356\n"
"๐ฒ๐ญ Marshall Islands +692\n"
"๐ฒ๐ถ Martinique +596\n"
"๐ฒ๐ท Mauritania +222\n"
"๐ฒ๐บ Mauritius +230\n"
"๐พ๐น Mayotte +262\n"
"๐ฒ๐ฝ Mexico +52\n"
"๐ซ๐ฒ Micronesia +691\n"
"๐ฒ๐ฉ Moldova +373\n"
"๐ฒ๐จ Monaco +377\n"
"๐ฒ๐ณ Mongolia +976\n"
"๐ฒ๐ช Montenegro +382\n"
"๐ฒ๐ธ Montserrat +1664\n"
"๐ฒ๐ฆ Morocco +212\n"
"๐ฒ๐ฟ Mozambique +258\n"
"๐ฒ๐ฒ Myanmar +95\n"
"๐ณ๐ฆ Namibia +264\n"
"๐ณ๐ท Nauru +674\n"
"๐ณ๐ต Nepal +977\n"
"๐ณ๐ฑ Netherlands +31\n"
"๐ณ๐จ New Caledonia +687\n"
"๐ณ๐ฟ New Zealand +64\n"
"๐ณ๐ฎ Nicaragua +505\n"
"๐ณ๐ช Niger +227\n"
"๐ณ๐ฌ Nigeria +234\n"
"๐ณ๐บ Niue +683\n"
"๐ณ๐ซ Norfolk Island +6723\n"
"๐ฐ๐ต North Korea +850\n"
"๐ฒ๐ฐ North Macedonia +389\n"
"๐ฒ๐ต Northern Mariana Islands +1670\n"
"๐ณ๐ด Norway +47\n"
"๐ด๐ฒ Oman +968\n"
"๐ต๐ฐ Pakistan +92\n"
"๐ต๐ผ Palau +680\n"
"๐ต๐ฆ Panama +507\n"
"๐ต๐ฌ Papua New Guinea +675\n"
"๐ต๐พ Paraguay +595\n"
"๐ต๐ช Peru +51\n"
"๐ต๐ญ Philippines +63\n"
"๐ต๐ฑ Poland +48\n"
"๐ต๐น Portugal +351\n"
"๐ต๐ท Puerto Rico +1\n"
"๐ถ๐ฆ Qatar +974\n"
"๐ซ๐ท Rรฉunion +262\n"
"๐ท๐ด Romania +40\n"
"๐ท๐บ Russia +7\n"
"๐ท๐ผ Rwanda +250\n"
"๐ง๐ฑ Saint-Barthรฉlemy +590\n"
"๐ธ๐ญ Saint Helena +290\n"
"๐ฐ๐ณ Saint Kitts & Nevis +1869\n"
"๐ฑ๐จ Saint Lucia +1758\n"
"๐ซ๐ท Saint Martin +590\n"
"๐ต๐ฒ Saint Pierre & Miquelon +508\n"
"๐ป๐จ Saint Vincent & Grenadines +1784\n"
"๐ผ๐ธ Samoa +685\n"
"๐ธ๐ฒ San Marino +378\n"
"๐ธ๐น Sรฃo Tomรฉ & Prรญncipe +239\n"
"๐ธ๐ฆ Saudi Arabia +966\n"
"๐ธ๐ณ Senegal +221\n"
"๐ท๐ธ Serbia +381\n"
"๐ธ๐จ Seychelles +248\n"
"๐ธ๐ฑ Sierra Leone +232\n"
"๐ธ๐ฌ Singapore +65\n"
"๐ธ๐ฝ Sint Maarten +1721\n"
"๐ธ๐ฐ Slovakia +421\n"
"๐ธ๐ฎ Slovenia +386\n"
"๐ธ๐ง Solomon Islands +677\n"
"๐ธ๐ด Somalia +252\n"
"๐ฟ๐ฆ South Africa +27\n"
"๐ฐ๐ท South Korea +82\n"
"๐ธ๐ธ South Sudan +211\n"
"๐ช๐ธ Spain +34\n"
"๐ฑ๐ฐ Sri Lanka +94\n"
"๐ธ๐ฉ Sudan +249\n"
"๐ธ๐ท Suriname +597\n"
"๐ณ๐ด Svalbard & Jan Mayen +47\n"
"๐ธ๐ฟ Swaziland +268\n"
"๐ธ๐ช Sweden +46\n"
"๐จ๐ญ Switzerland +41\n"
"๐ธ๐พ Syria +963\n"
"๐น๐ผ Taiwan +886\n"
"๐น๐ฏ Tajikistan +992\n"
"๐น๐ฟ Tanzania +255\n"
"๐น๐ญ Thailand +66\n"
"๐น๐ฑ Timor-Leste +670\n"
"๐น๐ฌ Togo +228\n"
"๐น๐ฐ Tokelau +690\n"
"๐น๐ด Tonga +676\n"
"๐น๐น Trinidad & Tobago +1868\n"
"๐น๐ณ Tunisia +216\n"
"๐น๐ท Turkey +90\n"
"๐น๐ฒ Turkmenistan +993\n"
"๐น๐จ Turks & Caicos Islands +1649\n"
"๐น๐ป Tuvalu +688\n"
"๐ป๐ฎ U.S. Virgin Islands +1340\n"
"๐บ๐ฌ Uganda +256\n"
"๐บ๐ฆ Ukraine +380\n"
"๐ฆ๐ช United Arab Emirates +971\n"
"๐ฌ๐ง United Kingdom +44\n"
"๐บ๐ธ United States +1\n"
"๐บ๐พ Uruguay +598\n"
"๐บ๐ฟ Uzbekistan +998\n"
"๐ป๐บ Vanuatu +678\n"
"๐ป๐ฆ Vatican City +39\n"
"๐ป๐ช Venezuela +58\n"
"๐ป๐ณ Vietnam +84\n"
"๐ผ๐ซ Wallis & Futuna +681\n"
"๐ช๐ญ Western Sahara +212\n"
"๐พ๐ช Yemen +967\n"
"๐ฟ๐ฒ Zambia +260\n"
"๐ฟ๐ผ Zimbabwe +263")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.