#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)("[^"]*"),"[^"]*","[^"]*"(,"[^"]*")"
Local $sString = ""1234","1234","S243","Text"" & @CRLF & _
""1234","1234","01A243","other Text""
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)